Bug #1976

Problème à l'affichage des périodes

Added by Dominique FERRAND about 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:10/03/2012
Priority:NormalDue date:
Assignee:Jérôme TRUFFOT% Done:

0%

Category:Saisie des services
Target version:0.2

Description

Bonjour,
Nous avons créé deux périodes S1 et S2 pour chaque composante. Nous avons du mal à les faire afficher dans l'ordre dans la LOV des lignes services.
Tout d'abord, elles s'affichaient systématiquement S2 puis S1 alors que dans la table elles apparaissaient bien dans l'ordre S1 puis S2 en les triant par rowid.
Je suis arrivée à les mettre en sens inverse dans la table (S2 puis S1 en triant par rowid) pour essayer d'inverser la tendance.
Maintenant on a le phénomène suivant:
- On créé un destinataire et on essaie directement de créer les lignes services ==> on a l'ordre inversé S2 puis S1.
- On créé un destinataire sans aller plus loin, on passe à un autre enseignant, on revient sur le premier enseignant, on retourne sur le destinataire créé précédement et on lui ajoute une ligne service et là on a le bon ordre S1 puis S2 dans la LOV.
Ce n'est pas bloquant mais j'aimerais bien comprendre comment ça marche...
On fait des démonstrations aux enseignants demain et vendredi et je pense qu'on va avoir des remarques....
J'aimerais savoir si je peux leur dire que ça va être corrigé et quand. Nous commençons la campagne le 15/10.
Merci d'avance de votre réponse.
Dominique.

History

#1 Updated by Jérôme TRUFFOT about 9 years ago

  • Category set to Saisie des services
  • Assignee set to Jérôme TRUFFOT
  • Target version set to 0.2

Bonjour,

Normalement, les périodes sont triées par leur date de début (dans la table PERIODE, cela correspond à la colonne D_DEBUT). Les périodes que vous avez définies ont-elles les mêmes dates de début ? Le lien entre un destinataire et ses périodes ne se fait pas exactement de la même façon suivant qu'il s'agit d'un destinataire nouvellement créé ou d'un destinataire existant, même si dans les 2 cas les périodes sont triées suivant cette date de début. Cela expliquerait le comportement que vous rencontrez.

Si ce n'est pas le cas, ou si c'est normal que vos 2 périodes ait la même date de début (je devrais peut-être ajouter la date de fin ?), il faudra que je regarde plus en détail. Ce serait toutefois étonnant que nous n'ayons pas rencontré ce problème...

Cordialement,
Jérôme

#2 Updated by Dominique FERRAND about 9 years ago

Mes excuses les lus plates pour vous avoir dérangé...
Nous avons initialisé la table des périodes en faisant des copier-coller avec toutes les mêmes dates.
Comme nous ne sommes pas dans le "vrai" Geisha, ça m'a echappé. J'ai pourtant l'habitude de cette opération chaque début d'année.
Désolée de vous avoir dérangé et fait perdre votre temps.
Ca marche bcp mieux maintenant.
Dominique.

#3 Updated by Jérôme TRUFFOT about 9 years ago

  • Status changed from New to Closed

Pas de problème. Voici un bug vite résolu.

Cordialement,
Jérôme

Also available in: Atom PDF